Expense claims and invoice payment confirmation unavailable for UK customers

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 10:37 CEST

Update

We are continuing to monitor for any further issues.
Posted Sep 30, 2025 - 18:46 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2025 - 18:45 CEST

Update

We are continuing to investigate on this issue.
Posted Sep 30, 2025 - 13:49 CEST

Investigating

We are currently investigating this issue and will provide updates as soon as possible.

Thank you for your patience and understanding.
Posted Sep 29, 2025 - 16:47 CEST
This incident affected: Invoices (Invoices) and Expense claims (Expense claims).