Duplicate card transactions for EEA customers

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 16:45 CEST

Monitoring

A fix has been implemented and we are monitoring the results.

Duplicate transactions or refunds have been offset by extra rows.
Posted Sep 23, 2025 - 10:54 CEST

Investigating

We are investigating this issue.

Duplicate settlements are appearing for the same payment authorization. The initial investigation shows those duplicate transactions were made on September 20th.

We will provide updates as soon as possible.

Thank you for your patience.
Posted Sep 22, 2025 - 11:48 CEST
This incident affected: Cards (Virtual Cards, Physical Cards, Subscription Cards).