Budgets Projections - Processing Delays

Incident Report for Spendesk

Resolved

This incident has been now resolved.
Posted Mar 03, 2026 - 17:35 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 17:00 CET

Identified

The issue has been identified and we are implementing a fix.

Access to the Budget feature is not impacted.
Posted Mar 03, 2026 - 11:26 CET
This incident affected: General (Budgets).