Unusual spike in declined transactions for invalid expiry date (UK customers)

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 16:24 CEST

Update

The issue has been identified.
We instruct our iOS customers to update their mobile app to version 2.72.0.
Posted Jun 19, 2025 - 09:05 CEST

Identified

This issue has been identified and a fix will be implemented.
Posted Jun 18, 2025 - 12:34 CEST
This incident affected: Cards (Virtual Cards, Physical Cards, Subscription Cards).