Spendesk Financial Services - Outbound payments sent to BNP Paribas accounts are rejected
Incident Report for Spendesk
Resolved
This incident has been resolved.
Posted Jul 09, 2024 - 12:53 CEST
Update
We are continuing to investigate this issue.
Posted Jul 09, 2024 - 12:37 CEST
Investigating
We are currently investigating this issue.
Posted Jul 09, 2024 - 12:37 CEST
This incident affected: Invoices (Invoices) and Expense claims (Expense claims).