SEPA file network incident impacting outgoing transfers

Incident Report for Spendesk

Resolved

This incident has been resolved.

The failed outgoing payments can be retried.
Posted Jul 25, 2025 - 10:17 CEST

Identified

On July 15th, a network issue from one of our partners affected some of our outgoing payment files.

We are currently investigating this issue and will provide updates.

Thank you for your patience.
Posted Jul 24, 2025 - 17:09 CEST
This incident affected: Invoices (Invoices) and Expense claims (Expense claims).