Delays and errors during card transaction processing

Incident Report for Spendesk

Monitoring

The AWS incident has been resolved and we are closely monitoring the results.
Posted Oct 21, 2025 - 11:54 CEST

Identified

Numerous AWS services are still degraded, and this has an impact on some of our provider's services.
This includes the following: not being able to create virtual card requests, view card details, card processing taking longer than expected.

We are closely monitoring the situation and will provide updates as soon as possible.

Thank you for your patience.
Posted Oct 20, 2025 - 16:55 CEST
This incident affects: Cards (Virtual Cards, Physical Cards, Subscription Cards).