Users cannot log into www.spendesk.com

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Nov 14, 2023 - 09:06 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2023 - 17:21 CET

Investigating

We are aware that customers cannot log into the platform.

Our technical teams are working to resolve this.

We apologize for any inconvenience this might cause.
Posted Nov 13, 2023 - 17:05 CET
This incident affected: General (Login).