High latency on the "All Payments" module

Incident Report for Spendesk

Resolved

This incident has been resolved. Thanks for your patience.
Posted Jun 30, 2025 - 17:15 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2025 - 11:50 CEST

Investigating

We are experiencing some latencies. As a result, the loading time on the "All Payments" module is higher than usual.
Posted Jun 30, 2025 - 10:31 CEST
This incident affected: General (All Payments module).