Errors when editing, preparing your payables and mobile app issues
Incident Report for Spendesk
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 12:36 CEST
Identified
We are currently investigating errors on our Bookkeep > Prepare tab and All payments. You may encounter issues when editing or preparing your payables. This incident can lead to the mobile app experiencing failures and latencies.

Our technical team is working on a fix, we will provide an update as soon as possible.
Posted Apr 23, 2024 - 11:00 CEST
This incident affected: Bookkeeping (Bookkeep > Prepare).