Amazon Payments – Card Tokenisation Failure

Incident Report for Spendesk

Update

Our banking team is currently in contact with our banking partner Visa to investigate the root cause of this incident. We apologise for the ongoing disruption and will provide further updates as soon as more information is available.
Posted Sep 17, 2026 - 10:09 CEST

Investigating

We are currently investigating an issue affecting merchant card tokenisation when customers try to add Spendesk cards on Amazon. Our technical team is actively working to understand the scope and identify the cause. We sincerely apologise for any disruption this may cause and will provide an update as soon as more information is available.
Posted Sep 16, 2026 - 16:52 CEST
This incident affects: Cards (Virtual Cards, Physical Cards, Subscription Cards).