Third-Party Service Disruption : Email Notifications – Microsoft Service Disruption

Incident Report for Spendesk

Resolved

The issue affecting email delivery to Microsoft-hosted mailboxes was fully resolved as of [time]. During the incident, some emails and Spendesk features relying on Microsoft’s services may have been affected. We apologize for the inconvenience and thank you for your patience.
Posted Sep 04, 2026 - 16:03 CEST

Monitoring

Microsoft has confirmed that the Exchange Online disruption is being resolved, and we are monitoring the situation for any remaining impact on Spendesk features. Email delivery may recover progressively while Microsoft completes the restoration. We apologize for the disruption and will confirm full resolution once it has been verified.
Posted Sep 04, 2026 - 13:23 CEST

Investigating

We are aware of an issue affecting one of our third-party partners that may impact some Spendesk features, including the delivery of emails to customers using Microsoft-hosted mailboxes. The issue is outside Spendesk’s systems, and we are dependent on the partner for further information and resolution. We apologize for any disruption this may cause and will share further updates when information becomes available.
Posted Sep 04, 2026 - 13:10 CEST
This incident affected: General (Email notifications).