Bookkeeping Export – Degraded Performance

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 11:06 CEST

Monitoring

The issue affecting bookkeeping data exports appears to be stabilizing. A fix has been deployed and our technical team is actively monitoring the situation to confirm full resolution. We apologize for the disruption caused, particularly to those impacted during month-end closing, and will provide a final update once we have verified that all systems are fully operational.
Posted Jun 29, 2026 - 09:12 CEST

Investigating

We are currently investigating a performance issue affecting the export of bookkeeping data. Our technical team is actively working to identify the root cause. We sincerely apologize for any disruption this may cause, particularly for customers working on month-end closing. We will provide updates as soon as new information is available.
Posted Jun 26, 2026 - 11:37 CEST
This incident affected: Bookkeeping (Bookkeep > Export (File-based exports), Bookkeep > Export (Native Integrations - Xero), Bookkeep > Export (Native Integrations - Netsuite)).