Incident - Cannot generate virtual cards

Incident Report for Spendesk

Resolved

This incident has been resolved.
We invite you to try again generating your virtual cards.

Thanks for your patience.
Posted Sep 08, 2023 - 12:33 CEST

Update

We are continuing to investigate this issue.
Posted Sep 08, 2023 - 09:09 CEST

Investigating

Some of Spendesk virtual cards cannot be generated (the card numbers appear as empty).

Our Banking Partner is actively looking into this.

Please accept our apologies for the inconvenience, and thank you for your patience.
Posted Sep 08, 2023 - 09:08 CEST
This incident affected: Cards (Virtual Cards, Subscription Cards).