Mobile (Android only): Mobile app crashes and restarts
Incident Report for Spendesk
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 14:51 CET
Investigating
We are aware that the app is crashing for some Android users.

Our technical teams are working to resolve this.

We apologize for any inconvenience this might cause.
Posted Feb 28, 2024 - 12:13 CET