Bookkeep - prepare page is unavailable

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 16:18 CEST

Update

This incident has been resolved and all Spendesk services are operating normally. We’re reviewing the incident and incorporating our findings to help prevent a recurrence. We’re sorry for the disruption and appreciate your patience.
Posted Apr 22, 2026 - 18:01 CEST

Investigating

We are currently investigating an incident affecting the Bookkeep section of our platform. The prepare page is unavailable. Our team is actively investigating the root cause. We will keep you updated as we make progress.
Posted Apr 22, 2026 - 15:59 CEST