[UK Entities] Partially degraded performance of KYC services

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 09:55 CEST

Investigating

Our partner identified a technical issue affecting the processing of the KYC verification checks for our UK entities.

Impact: Delay in KYC services for newly created account holders and also for the existing merchant and sub-merchants verifications and tax ID/company type checks.
Therefore, newly created account holders may experience a delay before they can begin processing transactions.

Their engineering team is currently investigating the issue.

Thanks for your patience.

Note(s):
EEA & US entities are NOT impacted.
Posted Sep 04, 2025 - 16:57 CEST
This incident affected: Cards (Virtual Cards, Physical Cards, Subscription Cards) and Settings (Settings).