The issue affecting invoice confirmation in the Review stage has been fully resolved. Users are now able to confirm invoices without error. We apologize for the disruption experienced during this period and thank you for your patience.
Posted Jul 28, 2026 - 11:23 CEST
Monitoring
We have identified the root cause of the issue affecting invoice confirmation in the Review stage. A fix has been deployed. Our technical team is monitoring the situation to confirm full resolution. We apologize for any disruption caused and will update you once we have verified that all systems are fully operational.
Posted Jul 28, 2026 - 11:13 CEST
Investigating
We are currently investigating an issue affecting the invoice confirmation feature in the Review stage. Our technical team is actively working to identify the root cause. We sincerely apologize for any disruption this may cause to your operations. We will provide updates as soon as new information is available.