Web application unavailable

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:10 CEST

Identified

We are currently experiencing a service outage affecting web browser users. Our web application is unavailable due to an ongoing infrastructure issue with our third-party provider.

Payment services and mobile users are not impacted.
Posted Jun 12, 2025 - 19:00 CEST
This incident affected: General (Login).