AWS Outage - Multiple services impacted

Incident Report for Spendesk

Resolved

This incident has been resolved by AWS. Services are back up and running as usual.
Thanks for your patience.
Posted Oct 20, 2025 - 13:40 CEST

Identified

Spendesk platform was impacted by the global incident happening with AWS (US-East).
Many services were degraded, such as:

- Latency in payments' execution and in-app display
- Latency in card requests: transaction processing and notification, card creation and validation, authorization declines, physical card shipping
- Latency in support services
Posted Oct 20, 2025 - 09:30 CEST
This incident affected: Cards (Virtual Cards, Physical Cards, Subscription Cards) and General (Email notifications).