Errors and high latency on Spendesk

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Jul 08, 2024 - 13:44 CEST

Identified

We are experiencing some latencies. As a result, the loading time is higher and some bookkeeping actions are impacted.

Our technical team is looking into this, and we will provide an update with sharable information, when possible.
Posted Jul 08, 2024 - 10:49 CEST
This incident affected: Bookkeeping (Bookkeep > Prepare) and Invoices (Invoices).