Some users can't log into Spendesk

Incident Report for Spendesk

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2025 - 08:54 CEST

Investigating

We are currently investigating this issue.
Posted Apr 14, 2025 - 11:55 CEST
This incident affects: General (Login).