Platform Service Disruption (Partial Outage)

Incident Report for Spendesk

Resolved

This incident has been resolved and all Spendesk services are operating normally. We’re reviewing the incident and incorporating our findings to help prevent a recurrence. We’re sorry for the disruption and appreciate your patience.
Posted Apr 17, 2026 - 13:15 CEST

Investigating

We’re currently investigating a general issue affecting parts of the Spendesk platform. Some services may be unavailable or slower than usual. Our team is actively working to identify the root cause and restore normal service. Thank you for your patience.
Posted Apr 17, 2026 - 11:40 CEST