Cannot access www.spendesk.com

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 18:03 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2025 - 15:50 CEST

Investigating

We are aware that www.spendesk.com is not accessible at the moment.

We are currently investigating this issue, and apologize for any inconvenience this might cause.
Posted Apr 10, 2025 - 15:24 CEST
This incident affected: General (Login).