Cloudfare global outage network: Spendesk is unavailable for some users

Incident Report for Spendesk

Resolved

The Cloudflare-related issue is resolved and Spendesk is fully operational. Thanks for your patience.
Posted Nov 18, 2025 - 18:09 CET

Monitoring

Cloudflare has implemented a fix and the incident appears stable. Some customers may still experience issues while all services fully recover, but we’re seeing improvements and are monitoring closely.
Posted Nov 18, 2025 - 16:15 CET

Identified

Spendesk is impacted by Cloudfare's global outage: as a consequence loading times are to be expected.

We will post updates as soon as possible.

Thank you for your patience.
Posted Nov 18, 2025 - 14:07 CET
This incident affected: General (Login).