Platform Service Disruption - Prepare page won't load payable

Incident Report for Spendesk

Monitoring

Monitoring: We are actively monitoring the ongoing login issue, as some users continue to experience disruptions.
Posted Apr 30, 2026 - 09:51 CEST

Investigating

We’re currently investigating an issue affecting the prepare page : payables won't load. Our team is actively working to identify the root cause and restore normal service. Thank you for your patience.
Posted Apr 28, 2026 - 11:05 CEST