All Payables page unreachable for some companies.

Incident Report for Spendesk

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 11:30 CEST

Investigating

We are currently investigating this issue.
Posted Apr 10, 2026 - 11:25 CEST
This incident affects: General (All Payables module).