Expenses requests showing an incorrect status

Incident Report for Spendesk

Update

We are continuing to monitor the situation.
Posted Apr 09, 2026 - 15:34 CEST

Monitoring

Fixes have been implemented and further improvements are being deployed.
Posted Apr 08, 2026 - 15:00 CEST
This incident affects: Expense claims (Expense claims).