Delays in email processing resulting in email notifications not received.

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 09:33 CEST

Identified

Our partner is still on a fix to resolve this issue.
Posted Sep 30, 2025 - 18:00 CEST

Investigating

Our email processor has identified the root cause of the issue.

We will provide updates as soon as possible.
Posted Sep 30, 2025 - 15:43 CEST
This incident affected: General (Email notifications).