3DS VISA card transactions not received.
Incident Report for Spendesk
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 08:35 CEST
Investigating
An ongoing issue prevents 3DS from being sent and causes user authentication and transactions to fail. This incident only affects VISA cards. We are actively looking into this. Please accept our apologies for the inconvenience, and thank you for your patience.
Posted Apr 09, 2024 - 18:46 CEST
This incident affected: Cards (Virtual Cards, Physical Cards, Subscription Cards).