The major latency issue affecting Spendesk has been fully resolved as of 11:59 AM CEST. The incident lasted approximately 1 hour and 55 minutes and affected platform access and performance for some users. We apologize for the disruption and thank you for your patience.
Posted Sep 02, 2026 - 11:59 CEST
Monitoring
The major latency issue affecting Spendesk has been mitigated. Our technical teams are continuing to monitor the service closely to ensure stability and confirm full resolution. We apologize for the disruption and will provide another update once normal performance has been fully verified.
Posted Sep 02, 2026 - 10:19 CEST
Investigating
We are currently investigating an issue affecting access to Speendesk on mobile and desktop. Our technical team is actively working to identify the cause of the connection errors and high latency. We sincerely apologize for the disruption and will provide further updates as soon as more information is available.