We have identified the root cause of the issue affecting Requests, Payables, Bookkeep, Invoices, and Expense Claims, which were not loading correctly. Our technical team is actively implementing a fix and working to restore full functionality as quickly as possible. We apologize for the continued inconvenience and will keep you updated on our progress.
Posted May 21, 2026 - 14:59 CEST
Investigating
We are currently investigating an issue affecting the Payables module, including the Bookkeep and Invoices tabs, where content may not be loading correctly. Our technical team is actively working to identify the root cause. We sincerely apologize for any disruption this may cause to your operations. We will provide updates as soon as new information is available.
Posted May 21, 2026 - 14:29 CEST
This incident affects: Bookkeeping (Bookkeep > Prepare) and Invoices (Invoices).