Cards blocked by PBR & not unblocking automatically

Incident Report for Spendesk

Update

We are continuing to work on a fix for this issue.
Posted May 05, 2026 - 13:21 CEST

Identified

We have identified a potential root cause of the issue affecting cards blocked by our Play-by-the-rules feature (PBR) not being automatically unblocked. Our technical team is currently testing a fix. We apologize for the continued inconvenience and will keep you updated on our progress.
Posted May 05, 2026 - 13:02 CEST

Investigating

We are currently investigating an issue where some cards recently blocked by our PBR (Play by the rule feature) system are not automatically unblocking as expected.
Our engineering team is actively working on a fix and is committed to resolving this as soon as possible. We apologize for the inconvenience.
Posted May 05, 2026 - 09:24 CEST
This incident affects: Cards (Virtual Cards, Physical Cards, Subscription Cards).