Incident - Cannot generate VISA virtual cards
Incident Report for Spendesk
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 14:09 CET
Investigating
Spendesk VISA cards cannot be generated (the card numbers appear as empty).

We are actively looking into this.

Please accept our apologies for the inconvenience, and thank you for your patience.
Posted Feb 29, 2024 - 12:32 CET
This incident affected: Cards (Virtual Cards, Subscription Cards) and Your Wallet (Account statements).