Platform Service Disruption : login access temporarily unavailable

Incident Report for Spendesk

Update

Monitoring: we are actively monitoring the ongoing login issue, as some users continue to experience disruptions.
Posted Apr 30, 2026 - 09:51 CEST

Monitoring

Monitoring — A fix has been implemented and the service has remained stable. We are continuing to monitor closely and will update this page if anything changes.
Posted Apr 28, 2026 - 15:04 CEST

Investigating

We’re currently investigating a general issue affecting parts of the Spendesk platform. As a result, login access may be temporarily unavailable for some users.
We sincerely apologize for the inconvenience this may cause and truly appreciate your patience during this time.
Posted Apr 28, 2026 - 13:12 CEST