iOS users cannot log into the mobile app nor confirm transactions

Incident Report for Spendesk

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 10:24 CEST

Update

An important iOS mobile update is now available to resolve this technical issue.
This update is for now only available for French customers, and will be progressively rolled out to other locations.

We recommend installing the latest version (2.73.0) right now for a better experience.
Posted Jun 25, 2025 - 15:37 CEST

Identified

The issue has been identified and we are working on a fix.

Wire transfer validations and revelation of secret number (UK customers) are also impacted.

Thank you for your patience.
Posted Jun 25, 2025 - 11:57 CEST

Investigating

We are currently investigating this issue.
Posted Jun 25, 2025 - 11:16 CEST
This incident affected: Cards (Virtual Cards, Physical Cards, Subscription Cards), Invoices (Invoices), Expense claims (Expense claims), and General (Login).