Error message on app.spendesk.com
Incident Report for Spendesk
Resolved
This incident has been resolved.
Posted Jul 24, 2024 - 12:14 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2024 - 12:13 CEST
Investigating
We are aware that customers cannot log into the platform and that all online payments with SFS EEA cards that require 3DS automatically fail. Our technical teams are working to resolve this. We apologize for any inconvenience this might cause.
Posted Jul 24, 2024 - 11:38 CEST